
Code Composer Studio v5 Users Guide 1

Code Composer Studio v5 Users Guide

Return to the Sitara Linux Software Developer's Guide

Overview
Code Composer Studio v5.1 is currently provided with the Sitara Software Development Kit. It uses the Eclipse
backend and includes the Remote System Explorer plug-in that provides tools to provide access to the remote target
board.

Locating the CCSv5 Installer

Using the SD Card Provided with the EVM
When the SD card provided in the box with the EVM is inserted into an SD card reader attached to a Linux system
three partitions will be mounted. The third partition, labeled START_HERE, will contain the CCS installer along
with the Sitara Linux SDK installer. The CCS installer is located inside of the CCS directory and there is a helper
script called ccs_install.sh available to help call the installer.

Downloading from the Web
The CCS installer is available for download as a compressed tarball (tar.gz) file on the same page as the Sitara Linux
SDK download. The installer can be located by browsing to http:/ / www. ti. com/ tool/ linuxezsdk-sitara [1] and
selecting the device being used. On the individual SDK download page you can find the CCS installer under the
Optional Addons section. i.e.

http://processors.wiki.ti.com/index.php?title=File:TIBanner.png
http://processors.wiki.ti.com/index.php?title=Sitara_Linux_Software_Developer%E2%80%99s_Guide
http://www.ti.com/tool/linuxezsdk-sitara
http://www.ti.com/tool/linuxezsdk-sitara
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Download.png


Code Composer Studio v5 Users Guide 2

Clicking this link will prompt you to fill out an export restriction form. After filling out the form you will be given a
download button to download the file as well as receiving an e-mail with the download link. Download the tarball
and save it to your Linux host development system.

Starting the CCSv5 Installer

Using the Sitara Linux SDK Installer
The Sitara Linux SDK installer has the capability of launching the CCSv5 installer during the SDK installation. In
order for the installer to launch the CCSv5 installer the CCS directory and ccs_install.sh script must be located in the
same directory as the Sitara Linux SDK installer. When installing from the SD card found in the EVM box this
directory and script are already located in the same directory as the Sitara Linux SDK installer. However, if you
downloaded the CCS installer tarball from the ti.com website as mentioned above, then you will need to:
1. Place the CCS tarball (the .tar.gz file) in the same directory as the Sitara Linux SDK installer
2. Extract the CCS tarball using a command like:

tar xzf CCS_<version>_Sitara_ARM.tar.gz
Where <version> is the version string of the CCS installer

After the CCS installer files are located in the same directory as the Sitara Linux SDK installer you can execute the
SDK installer to begin SDK installation. During the SDK installation you will see a scree similar to the one below.
The option to Install Code Composer is enabled by default.

NOTE: If the Install Code Composer option is selected and the CCS install files are not located in the same
directory as the Sitara Linux SDK installer you will be given a message that the installer could not be located and the
SDK installation will continue as normal. To install CCS later you can follow the steps in the next section to bypass
the Sitara Linux SDK installer.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-SDK.png
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From Linux Command Line
If you want to install CCSv5 apart from the Sitara Linux SDK installer, or if you decided not to install it as part of
the SDK install and want to install it now, you can install CCS using the following commands:
1. Open a Linux terminal and change directory to the location where the CCS files are located. This may be the

START_HERE partition of the SD card, or the location where you downloaded the tarball file from the ti.com
website.

2. If the CCS files are still in a compressed tarball extract them using the command
tar xzf CCS_<version>_Sitara_ARM.tar.gz
Where <version> is the version string of the CCS installer

3. Invoke the CCS installer using the ccs_install.sh script located in the START_HERE directory (copy the script to
your current directory).

./ccs_install.sh $PWD
NOTE: You can also invoke the CCS installer using in the CCS directory using the commands:

cd CCS
./ccs_setup*.bin --setupfile ccs_installini.xml

CCSv5 Installation Steps
NOTE: The 30-day trial version language in the CCS installer license agreement applies only for the case of using
high-speed JTAG emulators (does not apply to use of the XDS100v2 JTAG emulator). If a debug configuration is
used that requires a high-speed JTAG emulator, you will be prompted to register your software for a fee. All use of
CCSv5 (excluding use of high-speed JTAG emulators) if free and has no 30-day time limit.
When the CCSv5.1 installer runs you can greatly reduced the install time and installed disk space usage by taking the
defaults as they appear in this CCS installer. The screen captures below show the default installation options and the
recommended settings when installing CCSv5.
1. The License Agreement screen will prompt you to accept the terms of the license agreement. Please read these

terms and if you agree select I accept the terms of the license agreement. If not then please exit the installation.
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2. At the Choose Installation Location screen do NOT check Add TI plug-ins into an existing Eclipse install

3. At the Processor Support screen make sure to select the AMxx Cortex-A and ARM9 processors option

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-License.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-Location.png
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4. At the Select Components screen do NOT select TI ARM Compiler Tools. These tools are the TI compiler tools
for ARM devices, whereas for Linux the Sitara Linux SDK uses the open source GCC compiler.

5. At the Select Emulators screen make sure that JTAG Emulator Support is enabled but you do not need to select
individual emulators unless you require support for that model of JTAG. To install those drivers later see the
Installing Emulator Support section below.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-Processor.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-Components.png
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6. At the CCS Install Options screen verify that the options look correct and then select Next to begin installation.

7. After the installation has completed click Finish

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-Emulator.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-Install-Options.png
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Installing Emulator Support
If during the CCSv5 installation, you selected to install drivers for the Blackhawk or Spectrum Digital JTAG
emulators a script must be run with administrator privileges
to allow the Linux Host PC to recognize the JTAG emulator.  The script must be run as "sudo" with the following
command:

sudo <CCSv5_INSTALL_PATH>/ccsv5/install_scripts/install_drivers.sh

where <CCSv5_INSTALL_PATH> is the path that was chosen when the CCSv5.1 installer was run.

Launching CCS
After the CCS installer has finished executing you should have an icon on your desktop call Code Composer Studio
v5 like:

To launch CCS you should:
1. Double-Click the CCS icon on the desktop. You will see the CCSv5 splash screen appear while CCS loads

2. The next window will be the Workspace Launcher window which will ask you where you want to locate your
CCSv5 workspace. You can take the default here or choose a custom directory.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-icon.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-splash-screen.png
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3. CCS will load the workspace and then launch to the default TI Resource Explorer screen

4. Close the TI Resource Explorer screen. This screen is useful when making TI CCS projects which use TI tools.
The Sitara Linux SDK uses open source tools with the standard Eclipse features and therefore does not use the TI
Resource Explorer. You will be left in the Project Explorer default view.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-workspace.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-resource-explorer.png
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http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-project-explorer.png
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Enabling CCS Capabilities
Each time CCSv5.1 is started using a new workspace, additional capabilities need to be enabled so that perspectives
for those capabilities will be selectable in the Window -> Open Perspectives list.
After opening CCSv5.1 with a new workspace:
1. Open the Window -> Preferences menu

2. Go to the General -> Capabilities menu

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-window-preferences.png
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3. Select the RSE Project Capability

4. Click Apply and then OK

This enables the perspectives in the Window -> Open Perspective -> Other menu as shown below and is needed to
make the Remote System Explorer plug-ins selectable.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-general-capabilities.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-enable-rse.png
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Note: The Qt C++ Perspective is not compatible with this version of Eclipse. Instead Qt projects are to be
built using the Makefiles inside of the project as will be detailed in the later sections of this guide.

Importing Qt Projects
Since the Qt plugin does not work with the latest version of Qt the example projects have been modified to use a
Makefile to handle the build step. You can use projects like the matrix-gui-browser project as a reference for how
to configure a Qt project to build using a Makefile. The following steps detail the changes that should be made for an
existing Qt project to use a Makefile to build.

Importing matrix browser project
1. First import the Qt project using the File -> Import... menu
2. Select the Qt -> Qt Project option

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-open-perspective.png
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3. Press the Next > button
4. On the Import Qt Project screen click the Browse... button and locate the matrix_browser.pro file within the

<SDK INSTALL DIR>/example-applications/matrix-gui-browser-x.x directory

5. Click OK
6. You should now see the matrix_browser project listed as being selected for import into CCS

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-import-qt.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-select-matrix.png
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7. Click Finish to import the matrix-gui-browser project
8. You should now see the matrix_browser project in the Project view

9. Now you will need to add the Qt version found in the SDK to CCS. This can be done using Window ->
Preferences and selecting the Qt' menu item

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-import-matrix.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-matrix-browser.png
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10. Select the Add... button
11. In the Add new Qt version dialog fill in:

Version Name: AMSDK Qt
Bin Path: <SDK INSTALL DIR>/linux-devkit/bin
Include Path: <SDK INSTALL DIR>/linux-devkit/arm-arago-linux-gnueabi/usr/include/qtopia

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-preferences-qt.png
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12. Click Finish
13. Click Apply
14. When prompted that Qt versions have changed select Yes
15. Click OK

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-add-qt.png
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Changing the Make Target
By default the debug target is compiled when you selected to rebuild the Qt projects due to the Qt version change
above. You can build the release version by doing:
1. Right Click matrix_browser project
2. Select Make Targets -> Build...

3. Highlight Qt Release Build and click the Build button

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-make-target.png
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4. You will find the matrix_browser executable built in the matrix_browser project.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-release-build.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-matrix-build.png
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Creating a New Make Target
You may want to create additional make targets for steps like the installation step. In this example we will make an
install target that installs the release version of the matrix_browser executable.
1. Right click matrix_browser project and select Make Targets -> Create...

2. In the dialog box set:
Target name: install
Check Same as the target name for the Make Target

un-check Use builder settings

Change Build command: to make -f Makefile.build install

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-make-target.png
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3. Click OK

You can now build the install target using the steps in the Changing the Make Target section above.

Using a Makefile
In order for the above steps to work a Makefile.build Makefile was created in the matrix-gui-browser directory. This
Makefile.build has some key point that are worth mentioning.
• The Rules.make file is included from the top-level of the Sitara Linux SDK. This is to provide access to variables

like DESTDIR for installing the built executable.

-include ../../Rules.make

• There is a variable called EVN_SETUP that points to the environment-setup script in the linux-devkit directory.
The qmake target, which is used by the release and debug targets will first source the environment-setup script
to get access to qmake2 and configure the build to use the Qt version inside of the Sitara Linux SDK

qmake : matrix_browser.pro   //qmake target depends on 

matrix_browser.pro

        @ . ${ENV_SETUP}; \  //source the environment-setup script 

using a shell

        qmake2 CONFIG+=debug_and_release 

QMAKE_CXXFLAGS_DEBUG+=-D${PLATFORM_DEFINE} 

QMAKE_CXXFLAGS_RELEASE+=-D${PLATFORM_DEFINE} matrix_browser.pro  //call

 qmake2 to make the project Makefiles

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-make-install.png
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Installing to the Target File System
Depending on your file system type you can use the methods below to install the matrix_browser executable. If the
file system is NFS you should have first run the SDK Setup Script.
1. Create a Make Target using the steps in the Creating a New Make Target section above
2. Browsing to the <SDK INSTALL DIR>/example-applications/matrix-gui-browser-x.x/ directory in a terminal

and typing make -f Makefile.build install
3. For all file system types you can also transfer the file using the drag-and-drop method of Remote System

Explorer. See the Remote System Explorer section below for more details

Importing C/C++ Projects

Importing the Projects
The following instructions will help you to import the example C/C++ application projects into CCSv5. For
instructions on importing Qt application see the Importing Qt Projects section above.
1. From the main CCSv5 window, select File -> Import... menu item to open the import dialog
2. Select the General -> Existing Projects into Workspace option

3. Click Next
4. On the Import Projects page click Browse

http://processors.wiki.ti.com/index.php?title=SDK_Setup_Script
http://processors.wiki.ti.com/index.php?title=File:Import_C_projects-1.png
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5. In the file browser window that is opened navigate to the <SDK INSTALL DIR>/example-applications
directory and click OK

6. The Projects: list will now be populated with the projects found.
• NOTE: The matrix_browser project should be un-checked since this is a Qt project and should be imported

using the steps in the Importing Qt Projects section above.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-import-c.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-browse.png
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• NOTE: Some projects like dhrystone, linpack, and whetstone support multiple architectures. You should only
import one architecture of these projects at a time. You can determine the architecture by scrolling to the end
of the project name and looking for armv5te or armv7a. armv5te is for ARM9 devices and armv7a is for
ARM-Cortex devices.

7. Select the projects you want to import. The following screen capture shows importing all of the example projects
for an ARM-Cortex device, excluding the matrix_browser project.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-import-arch.png
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8. Click Finish to import all of the selected projects.
9. You can now see all of the projects listed in the Project Explorer tab.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-import-projects.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-projects-list.png
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Building C/C++ Projects
1. Right-Click on the project in the Project Explorer
2. Select the build configuration you want to use

• For Release builds: Build Configurations -> Set Active -> Release
• For Debug builds: Build Configurations -> Set Active -> Debug

3. Select Project -> Build Project to build the highlighted project
• NOTE: You can use Project -> Build All to build all of the projects in the Project Explorer

Installing C/C++ Projects
There are several methods for copying the executable files to the target file system:
1. Use the top-level Makefile in the SDK install directory. See the Top-Level Makefile section for details of using

the top-level Makefile to install files to a target file system.
• NOTE: The top-level Makefile uses the install commands in the component Makefiles and can be used as a

reference for how to invoke the install commands.
2. For all file system types you can also transfer the file using the drag-and-drop method of Remote System

Explorer. See the Remote System Explorer section below for more details

Creating a New Project
This section will cover how to create a new cross-compile project to build a simple Hello World application for the
target.

Configuring the Project
1. From the main CCSv5 window, select File -> New -> Project... menu item
2. in the Select a wizard window select the C/C++ -> C Project wizard

http://processors.wiki.ti.com/index.php?title=Sitara_Linux_Software_Developer%E2%80%99s_Guide%23Top-Level_Makefile
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-new-c-project.png
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3. Click Next
4. In the C Project dialog set the following values:

Project Name: helloworld

Project type: Cross-Compile Project

5. Click Next
6. In the Command dialog set the following values:

Tool command prefix: arm-arago-linux-gnueabi-. Note the the prefix ends with a "-". This is the prefix of the
cross-compiler tools as will be seen when setting the Tool command path

Tool command path: <SDK INSTALL DIR>/linux-devkit/bin. Use the Browse.. button to browse to the
Sitra Linux SDK installation directory and then to the linux-devkit/bin directory. You should see a list of
tools such as gcc with the prefix you entered above.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-cross-compile.png
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7. Click Next
8. In the Select Configurations dialog you can take the default Debug and Release configurations or add/remove

more if you want.

9. Click Finish

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-command-setup.png
http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-select-configurations.png
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Adding Sources to the Project
1. After completing the steps above you should now have a helloworld project in your CCS Project Explorer

window, but the project has no sources.

2. From the main CCSv5 window select File -> New -> Source File menu item
3. In the Source File dialog set the Source file: setting to helloworld.c

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-empty-helloworld.png
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4. Click Finish

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-helloworld-c-file.png
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Cross-Compiling the Sources
1. After completing the steps above you will have a template helloworld.c file. Add your code to this file like the

image below:

2. Change the build configuration to Release by selecting Project -> Build Configurations -> Set Active ->
Release

3. Compile the helloworld project by selecting Project -> Build Project
4. The resulting executable can be found in the Release directory

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-helloworld.png
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5. You can now install the executable to the target file system using Remote System Explorer, NFS, or any other
method you want.

Remote System Explorer
CCSv5 as installed with this SDK includes the Remote System Explorer (RSE) plug-in.  RSE provides
drag-and-drop access to the target file system as well as remote shell and remote terminal views within CCS. Refer
to How to Setup and Use Remote System Explorer to establish a connection to your target EVM and start using
RSE.

Using GDB Server in CCSv5 for Linux Debugging
In order to debug Linux code using Code Composer Studio v5, you first need to configure the gdbserver on both the
host and target (EVM) side.
Please refer to Running GDB Server on CCSv5 for more information.

http://processors.wiki.ti.com/index.php?title=File:Sitara-Linux-CCS-helloworld-built.png
http://processors.wiki.ti.com/index.php?title=How_to_setup_Remote_System_Explorer_plug-in
http://processors.wiki.ti.com/index.php?title=How_to_Run_GDB_on_CCSv5
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Archived versions
• Sitara SDK 05.03 CCSv5 User Guide (archived) [2]

• Sitara SDK 05.02 CCSv5 User Guide (archived) [3]
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License
THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER
APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.
BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE
A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.
License
1. Definitions
a. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or

phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work
that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in
timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.

b. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(f) below,
which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting
separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined below) for the purposes of this License.

c. "Creative Commons Compatible License" means a license that is listed at http:/ / creativecommons. org/ compatiblelicenses that has been approved by Creative Commons as being essentially equivalent to this License,
including, at a minimum, because that license: (i) contains terms that have the same purpose, meaning and effect as the License Elements of this License; and, (ii) explicitly permits the relicensing of adaptations of works made
available under that license under this License or a Creative Commons jurisdiction license with the same License Elements as this License.

d. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.

http://creativecommons.org/compatiblelicenses
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e. "License Elements" means the following high-level license attributes as selected by Licensor and indicated in the title of this License: Attribution, ShareAlike.
f. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.
g. "Original Author" means, in the case of a literary or artistic work, the individual, individuals, entity or entities who created the Work or if no individual or entity can be identified, the publisher; and in addition (i) in the case of a

performance the actors, singers, musicians, dancers, and other persons who act, sing, deliver, declaim, play in, interpret or otherwise perform literary or artistic works or expressions of folklore; (ii) in the case of a phonogram the
producer being the person or legal entity who first fixes the sounds of a performance or other sounds; and, (iii) in the case of broadcasts, the organization that transmits the broadcast.

h. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression
including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a
musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or
lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography,
topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not
otherwise considered a literary or artistic work.

i. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise
rights under this License despite a previous violation.

j. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to
make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the
communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.

k. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected
performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights
Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other
applicable laws.
3. License Grant
Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated
below:
a. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
b. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original

Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
c. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
d. to Distribute and Publicly Perform Adaptations.
e. For the avoidance of doubt:

i. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right
to collect such royalties for any exercise by You of the rights granted under this License;

ii. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor waives the exclusive right to collect
such royalties for any exercise by You of the rights granted under this License; and,

iii. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via
that society, from any exercise by You of the rights granted under this License.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and
formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved.
4. Restrictions
The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:
a. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or

Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License.
You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly
Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License.
This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from
any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(c), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable,
remove from the Adaptation any credit as required by Section 4(c), as requested.

b. You may Distribute or Publicly Perform an Adaptation only under the terms of: (i) this License; (ii) a later version of this License with the same License Elements as this License; (iii) a Creative Commons jurisdiction license
(either this or a later license version) that contains the same License Elements as this License (e.g., Attribution-ShareAlike 3.0 US)); (iv) a Creative Commons Compatible License. If you license the Adaptation under one of the
licenses mentioned in (iv), you must comply with the terms of that license. If you license the Adaptation under the terms of any of the licenses mentioned in (i), (ii) or (iii) (the "Applicable License"), you must comply with the
terms of the Applicable License generally and the following provisions: (I) You must include a copy of, or the URI for, the Applicable License with every copy of each Adaptation You Distribute or Publicly Perform; (II) You
may not offer or impose any terms on the Adaptation that restrict the terms of the Applicable License or the ability of the recipient of the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable
License; (III) You must keep intact all notices that refer to the Applicable License and to the disclaimer of warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform; (IV) when
You Distribute or Publicly Perform the Adaptation, You may not impose any effective technological measures on the Adaptation that restrict the ability of a recipient of the Adaptation from You to exercise the rights granted to
that recipient under the terms of the Applicable License. This Section 4(b) applies to the Adaptation as incorporated in a Collection, but this does not require the Collection apart from the Adaptation itself to be made subject to
the terms of the Applicable License.

c. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the
medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute,
publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the
extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with
Ssection 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The
credit required by this Section 4(c) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of
the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this
Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the
Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.

d. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections,
You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in
which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's
honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this
License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer
UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING
THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE,
NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT
ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.
6. Limitation on Liability
EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE
OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
7. Termination
a. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License,

however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
b. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different

license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this
License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous
a. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
b. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
c. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this

agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
d. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent.
e. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not

be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
f. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979),

the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject
matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the
standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the
license of any rights under applicable law.
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